You can only play the game with recommended graphic drivers and DirectX 9.0 or above. The game may not run smoothly if the version doesn’t match.

EXE

US Client Download

55fd20e884aa6cbd963b69e381f4eb34c9358966
04_edited_edited_edited.jpg

US Client [EXE]

01_edited.jpg

US Client [ZIP]

ZIP

EN Client Download

1920px-Flag_of_the_United_Kingdom.svg.pn
04_edited_edited_edited.jpg

EN Client [EXE]

01_edited.jpg

EN Client [ZIP]

* If the download button does not function properly, please try opening a new tab or a new window by right clicking the button and try downloading again

EXE: Run and install to play the game

ZIP: Unzip the file to play the game

Syetem Requirements

flyff_logo.png